0

Exporting the results of a shortest path analysis through the Road Graph plugin in QGIS 2.0.1 results in an "empty" layer.

After running teh shortest path calculator, I selected export --> new temporary layer. I select the coordinate system (WGS84 - UTM18N)

Note in the photo, that a path on my roads vector layer is selected (red) by Road Graph, but the attribute table is empty. When I save this temporary layer permanently, the layer remains empty as well.

Please send instructions on how to make the export work/another way to save shortest paths as separate shapefiles.

enter image description here

  • I have this problem, too. The routing with the road graph plugin is working as I am used to from previous QGIS-Versions. But the export doesn't work. Neither the export to a temporary file nor the export to an existing shape-file. First I tried the standalone 64bit-version of QGIS 2.0.1, after this I installed the 32bit-version on another computer with the OSGeo4W installer. The result is the same on both computers: The attribut table stays empty, no geometries created during the routing calculations can be exported. – Setraworks Jan 25 '14 at 20:31
1

I ran into the same problem this week, and eventually installed QGIS 1.8 (didn't even need to uninstall 2.0). In v1.8, Road Graph exported my shortest path results to a shapefile just fine, which I was then able to use in 2.0.

  • Thus it appears to be a bug related to QGIS 2.0 and should be reported. Maybe the original developer has time to fix it. – Curlew Jan 24 '14 at 19:02
0

If you don't mind using a different tool, see my answer concerning a routing script for the Processing toolbox How do i draw a route on Quantum GIS between nodes?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.