4

I am trying to print a WMS map in QGIS.

If, while in the print composer, I chose a "25000" scale, the composer chooses a WMS layer that actually shows a 1:50000 map. To get down deep at the 1:25000 WMS map in the print composer preview, I have to trick it by telling the composer to use a smaller scale, but then I don't get the scale I want.

How does QGIS choose its WMS zoom level?

I need to chose a scale AND a specific WMS zoom level. I tried the "Lock layers for map item" check box but it is not what I hoped for.

  • Do you mean that if you select 1:50000 scale in the QGIS map window and in the composer you are seeing different WMS zoom levels in those two= – user30184 May 30 '14 at 7:37
  • 1
    I'm having the same issue I think - and (IF I'm right) it might help to clarify the question by dropping the reference to 'scale'. Scale questions bring in all sorts of other factors to the question, when what your question is actually only how to make sure that the WMS tiles selected are at a particular zoom level. Zoom level and scale obviously are separate things - given that you could print/display tiles at a given zoom level at a scale of your choice. As a work-around/partial solution note that changing the resolution used for the composer output changes the tile zoom level used. – Rostranimin May 30 '14 at 9:23
  • Perhaps they heard us. It looks like the new Print Composer in QGis 2.4 has some nice features: Improvements to composer picture items "The image item in composer is now 'atlas friendly' - you can use an expression to define which image should be shown for each atlas page. You can also now set the resize mode (zoom, clip, stretch etc.) for the image in relation to its frame size and dimensions. You can also specify the placement of the image relative to its frame using the new placement item property." It looks like it could be what I'm looking for :) – Dakatine Jun 30 '14 at 10:59
  • Well, actually, 2.4 is out but I'm in no way able to solve this unfortunately. – Dakatine Sep 12 '14 at 10:48
1

I had exactly the same problem Dekatine describes in his question 29 May 2014, with QGIS version 2.10.1. I used a raster map provided WMS from Finnish Land Use Service (an authority providing WMS).

Normally I get the cascade of maps from server and the program chooses the right scale map automatically when I zoom in or out on my display. This automatic function does not work properly with print composer, as Dekatine described (the program just gets wrong map when you try to adjust the scale on map item tab - it tends to get larger scale map than you have written to the scale field, eg. I got 1:100000 map, when adjusted scale 1:45000 - I wanted 1:50000 map of course, which is closer to 1:45000 and more detailed).

I circumvented this problem by connecting to wms again, choosing and getting the map of certain scale only (1:50000) and made it active on main display of QGIS.

After that, I opened the print composer and I got this map as background. This is not of course the way it should work, but when desperate, you can at least proceed with your work.

1

I have had the same problem - when choosing a high resolution for the export of a map as a picture, I got the a very detailed zoom-level for the WMS background map. The solution I found was to de-activate the checkbox "Print as raster" in the layout-settings in the Print composer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.