3

Maplex has a nice feature which can abbreviate labels based on a dictionary that you configure. eg, replace STREET with ST.

However, it seems to be an all-or-nothing setting, with Maplex always replacing the words in the dictionary, even when the abbreviation is not necessary.

In the case below, Maplex has abbreviated STREET even though the word would easily fit in all cases:

with abbreviation dictionary on

with abbreviation dictionary off

In these examples, I want SKITTLE LN and TEMPERANCE LN to be abbreviated, but not the STREET names.

Edit:

According to the Help File entry mentioned by ChrisW:

the Maplex Label Engine first attempts to place the full text of the label, then abbreviates any words found in the dictionary for labels that could not be placed.

Why then is Maplex abbreviating the word STREET in these examples below?

enter image description here

I've simplified the options so that the only Fitting Strategy used is Abbreviation Dictionary. The style is Centered Straight with Regular placement. Using a line featureclass in an fGDB. The selected line is a single feature, so it's clear there is ample room for the full label. There are no other layers drawn.

It sure looks like a bug to me....

  • 1
    Odd; my understanding from the help file is that's how it's supposed to work - place full text unless label can't be placed, then abbreviate. In the fitting strategy tab you can also change the order of the enabled strategies - might that be affecting when it's used (ie default is abbreviate last, has the order been changed)? Or perhaps some combination with other strategies is triggering a lack of space? Or interaction with other layers and placement properties? Bug? – Chris W Sep 10 '14 at 21:52
  • Thanks @ChrisW - I've added a new screenshot showing a single line featureclass with no other fitting strategy options aside from the dictionary. – Stephen Lead Sep 10 '14 at 23:19
  • PS I just made a brand new MXD using only this layer, and the same problem occurs. Also with a totally unrelated shapefile. I think my version of Maplex is borked. – Stephen Lead Sep 11 '14 at 0:09
  • In your dictionary, is the abbreviation type defined and if so set to ending rather than translation? I note translation (0) always takes effect, while endings (2) only apply to the last word. And keywords (1) to anything but the last word. If they're not explicitly defined in the dictionary, perhaps it's defaulting to 0 and that's always making the abbreviation? It shouldn't per the whole 'only if it doesn't fit' thing, but it's the only other thing I can think of. – Chris W Sep 11 '14 at 19:18
  • I've actually given up on Maplex for this project - we're doing it in Illustrator instead. So I'll return to this if time permits - but for the moment, it seems to be a flaw/bug in Maplex. Thanks for the help to date. – Stephen Lead Sep 12 '14 at 1:38
2

I can confirm, this appears to be the behavior I am seeing as well (ArcMap 10.2.1). I have the Abbreviate Label last on the Fitting Strategy Order (with Stack Label and Reduce Size enabled). As long as the Abbreviate Label check box is enabled, Maplex abbreviates the label, regardless of space. This functionality is clearly not behaving as it is intended.

1

After encountering the same problem, I found changing the Type field in the dictionary to 'Ending' rather than the default 'Translation' fixed it for me (ArcMap 10.4.0). This worked for my purposes as I was only looking to abbreviate road suffixes (i.e. Street > St).

  • I've long since finished this project, but this looks like a good tip. I'll check it out if time permits. Thanks! – Stephen Lead Oct 6 '16 at 22:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.