0

I'm trying to install and run the Boundless SDK according to: http://suite.opengeo.org/opengeo-docs/webapps/install.html. I've tried running:

$ suite-sdk
bash: /usr/bin/suite-sdk: Permission denied
$ sudo suite-sdk // with and without the help and create commands
sudo: suite-sdk: command not found

So I know that I am calling suite-sdk from the right place. I have jdk6 and Ant both installed.

java version "1.6.0_33"
OpenJDK Runtime Environment (IcedTea6 1.13.5) (6b33-1.13.5-1ubuntu0.12.04)
OpenJDK 64-Bit Server VM (build 23.25-b01, mixed mode)
Apache Ant(TM) version 1.8.2 compiled on December 3 2011

My /etc/environment files is:

PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"
JAVA_HOME="/usr/lib/jvm/java-6-openjdk-amd64/jre/bin"

(I've also tried the JAVA_HOME path with and without /bin and /jre)

Does anybody know what I am doing wrong?

2

You will need to manually give the command execute permissions with chmod, this will be fixed in the upcoming release, see https://github.com/boundlessgeo/suite/issues/611 for more info

  • Thank you! I had to chmod the suite-sdk executable, rather than it's shortcut in the usr/bin folder. As well as add an ANT_HOME to etc/environment. Thanks for the help! – Jordan Quan Nov 21 '14 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.