1

Using QGIS 2.6.0 Brighton, I want to overlay a shapefile (EPSG: 26910, Nad83 UTM10) over OpenLayers Google Satellite (EPSG: 3857, Pseudo Mercator), and reliably measure distances. Furthermore, I want to teach with little knowledge of coordinate systems how to do so.

The process is to add the shapefile, then add Google Satellite. The project CRS switches to EPSG:3857, and the shapefile is correctly overlaid (well, sometimes imagery shows up in the wrong place, but that's another question). The measure tool does not report correct distance - not surprising, since the CRS is 3857. I do not want to change the CRS because then imagery shifts unexpectedly. So, I change the measure tool ellipsoid in Project Properties to 'GRS 1980'. Hit 'OK' to return to map. The measure tool reports correct distance.

However, if I ever open Project Properties again, the measure tool ellipsoid has defaulted back to 'None/Planametric'. If I hit 'OK' to return to map, the measure tool now reports incorrect distance, presumably because the map plane is unprojected.

Since I seem to be stuck using EPSG:3857 to accommodate OpenLayers, how can I change the default measurement ellipsoid?

  • Looks like a bug. Please report it. – underdark Nov 21 '14 at 22:40
1

Seems like the settings are not stored correctly. Here's the bug report for future reference http://hub.qgis.org/issues/11713

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.