1

We're trying to enable enterprise geodatabase functionality in an existing PostgreSQL database. We've already created the sde user (set as superuser) & sde schema.

We get the following error:

enter image description here

"Could not create geodatabase tables and stored procedures. Failed to execute (EnableEnterpriseGeodatabase).

the database is: "PostgreSQL 9.2.9 on x86_64-unknown-linux-gnu"

client: ArcGIS 10.2
  • 1
    Please always include errors as text so that they can be searched for in the future. – PolyGeo Jun 19 '15 at 10:04
  • PG 9.2 was not supported until ArcGIS 10.2, but this error may be due to database name (only lowercase is allowed) or failure to name the SDE schema "sde". Please edit the question to include the input parameters to the CreateEnterpriseGeodatabase tool. – Vince Jun 19 '15 at 10:30
  • It's 10.2 (sorry, my mistake). it's sde (with lowercase). We didn't use CreateEnerpriseGeodatabse, because the database was already created. We used Enable Geodatabase. – Ligia Jun 19 '15 at 14:12
-1

We had other schemas as well, and the sde user didn't have access to them, it had access only to the sde schema. In conclusion, the geodatabase administrator must have access to all the schemas that exist in the database.

  • This is not true. The 'sde' schema only needs access to the database which is being enabled. And you don't mention that ArcGIS10.1 installation in 9.2 not possible. – Vince Jun 19 '15 at 11:17
  • It's ArcGIS 10.2 (my mistake), and a PostgreSQL 9.2.9 – Ligia Jun 19 '15 at 14:07
  • Maybe it's a coincidence, but the moment we gave sde user access to the others schemas in the database, we got rid of the error and we succeeded in enabling the gdb. – Ligia Jun 19 '15 at 14:14
  • 3
    Best practice is to use CreateEnterpriseGeodatabase at least once, so you get an idea of how it's expecting things. I continue to use Create EGDB (vice Enable EGDB) even when the database exists and the sde login, user, and schema are all present (it skips those steps with warnings but not errors). As it stands, this "solution" will not work for others. – Vince Jun 19 '15 at 22:08
  • 2
    You can't, but you can use it on an existing database. – Vince Jun 22 '15 at 10:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.