I currently have little experience in the opensource area and I'm guessing this is where I need to go if I want to create a WMS Service without needing ArcGIS Server. Basically my goal is to take a local geo-referenced image (geo-jpeg) and create a WMS service to display that image. I've done some searching on this topic and I can't seem to find any specific information on this. I would prefer not needing to create a MapServer installation but if that's one of my best options, I will try going that route. So at this point I was hoping for some direction on how to create a WMS service, hopefully without needing to setup my own server. Maybe a blog post or tutorial on doing this. Thanks...


For a non-programming (but not FOSS) way you could create a free account and try to upload your image to GIScloud. WMS is one of the outputs you can get fron your project there. Check docs for more information.

For more ambitious way - GeoServer might be good way. I find it easier to interact with than MapServer. Check OpenGeo tutorials for a good starting point.

  • 1
    thanks for the tip with GISCloud. So I went ahead and tried this, enble the WMS feature for the map I created but I can't see to get any GIS clients to connect to the WMS address given. All I get is failed to connect when I paste the WMS address given. Is there something more I need to do or add to the address? – wilbev Oct 20 '11 at 0:10
  • @wilbev: Where did you paste the link exactly? If you want to have a quick preview you can display your WMS layer in QGIS - just hit the button 'Add WMS layer' and fill parameters. If you want to display it in a browser you can generate a code for Google Maps overview with GISCloud. Or build a simple viewer with, OpenLayers or Leaflet. – radek Oct 20 '11 at 8:19
  • I have tried in QGIS. I paste the exact URL from the WMS tab in GIS Cloud in the URL field. The error message I get back is"Could not understand the respone. The wms provider said: Download of capabilities failed: Error downloading...gives the WMS address and says server replied: Internal Server Error. Maybe something is wrong on GIS Cloud's side with this? Also, I tried to the Google Maps too, and it will takes me to the correct location but it's not displaying the raster layer for some reason. – wilbev Oct 20 '11 at 19:26
  • @wilbev: Strange. Perhaps try Map > Share and Publish > Embed. choose either option that is convenient for you and hit 'Popup preview'. – radek Oct 20 '11 at 19:58
  • radek: That's what I did to attempt to use the Google Maps. When I click on the Popup preview, it only shows the Google map basemap, where the image is located but no raster image is shown. I have no idea why the WMS url doesn't work. Are you able to get them to work with no problems? I even tried a second account and I get the same result. Unless I'm doing something wrong, which I'm not doing much other than copying a url, I can't see this working for anyone. – wilbev Oct 20 '11 at 21:12

I have a tutorial that describes how I set up GeoServer for this using the Blue Marble dataset. It should take you about an hour assuming you are reasonably happy with installing software on your system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.