3

I am currently using QGIS 2.10.1. and I am not able to select any layer when trying to configure the Road Graph plugin. What should I do?

  • When installed and enabled, you can select a layer if you go Vector > Road graph > Settings from the toolbar. Then you should be able to set the line layer input and parameters from there :) – Joseph Oct 13 '15 at 11:48
  • Maybe I didn't express myself properly, but my point is that after I am entering in the Settings for Road Graph, I am not able to select any layer. – Adela-Ioana Moldovan Oct 13 '15 at 12:03
2

The QGIS Road Graph Plugin can not use Polyline with Z-values. I solved this problem by removing Z-Values from my polyline shapefile. In QGIS: right mouse click on the layer /Save as... under Geometry choose Geometry type and uncheck Include z-dimension. Here is also a solution with ArcGIS.

  • 1
    By following the link in your answer it seems that this solution uses ArcGIS for Desktop but the asker makes no mention of using that product. – PolyGeo Oct 7 '16 at 10:16
1

right click the road layer and press save as. Then under geometry choose LineString and uncheck z-dimension. The z-dimension may have caused the problem. then try again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.