2

I am trying to use the integrated GPS module from QGIS to add data points to a shapefile while in the field. I managed to get the connection between qgis and the gps working and my location is shown on the map inside QGIS. When I create a new point shapefile, selecting UTM Zone 32N and add a point over the GPS module, a point is added to my shapefile but when I try to zoom to the points I receive the error message "missing geometry". When I try to add a track it works fine.

I have tried using QGIS 2.12 and 2.14 on several different computers with Win 7 and Win 10 and using different projections. While searching for the problem i have not found any solutions.

EDIT: Problem was fixed in the 2.14 LTR and the Versions since 2.16

  • GPS data is alayws in WGS84 EPSG:4326, so I suggest to use that CRS for any data received from a GPS unit. – AndreJ Jun 1 '16 at 5:20
  • Yep same issue here. i triend on win 7 win 8 mac, it wont work for the point – user76520 Jun 21 '16 at 5:17
4

I had the problem in the field yesterday after changing over to 2.14. I had correct layer type and projections and it would not add a point in the map from the GPS, but it would add the information to the table. I just went back to 2.8.9 all is OK. Seems to be a problem with 2.14.

  • 1
    I can verify this behavior in 32 Bit Version 2.14.3 on a tablet PC running Windows 8.1. The GPS unit is a Garmin GLO Bluetooth GPS/Glonass receiver operating at 10HZ. QGIS will track points, and draw lines in a polyline layer, but it will not plot individual points. Nor does will it update the table with the geometry of the points seemingly recorded. A row of data is created when a point is recorded, but there are no values stored. I have tried adding points to both Shape files, and Spatialite files, with no success. Version 2.8 does not seem to be affected. – jbgramm Jun 1 '16 at 17:05
1

I try to keep my desktop projects separate from my field data during data collection, and only go back to my desktop for processing and analysis. I will advice you to get your geometric points on the field and extract them into Qgis as a new layer and move on smoothly.

  • Depending of what kind of data you collect in the field, i would do that as well. But as i have to collect data points using GPS and add tons of further information to this specific point, its easier to use Qgis with GPS support in the field. I could use papernotes.. but as soon as it rains.. your notes have a problem, while i can still use qgis on a waterproof device.. furthermore.. i dont have to digitalize the paper stuff. – Firefly May 28 '16 at 15:59
1

If you are editing a shape file made up of polygons, you cannot add a point to it. If you are logging track points along a line you wish to collect, you need to add the line when you are finished logging the tracking points. Shape files are restricted to a specific, and single vector type for each layer. Points Lines Polygons You cannot mix, and match them.

Even though you say you have created a point shape file, it sounds to me as if you have created a polyline, or polygon layer if it is adding a track.

I have also found that it is necessary (for my purposes) to make all of the layers in the project the same projection. I have ended with the same issue when recording field data in one projection while it is overlaid on a project in another projection. This is especially true if you are going to buffer an object or perform a spatial query on an object that you have logged in the field.

  • Thanks for your reply. I created a point shapefile for adding points to my data set. When trying the track function, i used a polyline layer. I will recheck the projection. Maybe thats the fault. – Firefly May 28 '16 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.