I am trying to put together a demo-laptop with QGIS and gps.

On other computers I have it working as expected, but on this particular box something is strange.

What I get is a gps position about 680 meters south east of my position. The position is fixed in QGIS, it is not "walking around" as expected. I see the altitude is changing though, but not lon lat.

I have tried both connecting directly through /dev/rfcomm0 and through gpsd, same result.

In other clients everything looks ok, like Foxtrot GPS and gpsmon. In gpsmon, and Foxtrot gps I get another position than in QGIS and the position in the other clients is moving around.

I have moved the laptop and tried at another location and I get the same behavior but with another position some hundred meters away.

I did get desperate and re installed the laptop, but get the same behavior.

I am totally confused. It cannot be a hardware problem I think since it is working on other clients in the same laptop. It shouldn't be a software problem either since I have re installed everything including the OS.

As mentioned, I get it working on other computers with the same software.

My setup is: OS Ubuntu 11.04 QGIS compiled from trunk a few days ago

I can think of two reasons, but don't know how to search:

  1. Something in my hardware gives another configuration when I am compiling QGIS than on the other computors
  2. I have some software-package present (that I apparently also re installed in that case) that is interfering.

1 Answer 1


Based on my experience it could be the laptop is reading the gps data wrong. I have to use a serial to usb converter for my old garmin12. On my Win7 laptop sometimes it will connect the serial device as a mouse, which indeed operates as mouse, jumping around the screen and even grabbing things. QGIS is specific about the type of gps input. hth

  • But then, why is it working on other clients on the same laptop? Apr 24, 2012 at 21:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.