3

I'm completing online course GST 101 for QGIS (my version is 2.18.3) and I'm stuck on the Buffer tool.

All of my layers are set to CRS "NAD83(HARN)/New Mexico Central (ftUS) (EPSG:2903)" as instructed in the lab.

The goal is to use the query builder to filter the municipal limits in Bernalillo county down to only Albuquerque. Then after filtering create a buffer layer of 5280 ft around it.

The problem is I get an empty layer from the buffer tool with no entries in the attribute table. So I tried Buffer on the entire layer (with 0 ft buffer to pinpoint the problem areas) and this is the result.

enter image description here

There appears to be a number of features in this layer that aren't recognized because I would have expected the entire layer to be selected.

I've also tried the query builder to filter Albuquerque and save to a new layer. Then try to buffer the new layer, still results in an empty attribute table.

I've tried the shp file included in the lab as well as downloading the file directly from here: City of Albuquerque GIS Data (Municipal Limits / Various municipal limits in Bernalillo county / SHP File).

I'm still fairly new at GIS but I'm following a youtube video and pdf instruction but I'm clearly on a newer version of QGIS.

Any suggestions on what the problems may be?

3
  • 2
    I've just tried this and it worked fine for me - how are you selecting Alberque?
    – Ian Turton
    Feb 18, 2017 at 11:55
  • @iant I'm using the Query Builder in the General tab for the properties of that layer and using field JUSRISDICTI equal to ALBUQUERQUE with no issues. I can't get the buffer to work properly with or without a filter. Are you saying you are able to create a buffer of 5280 ft around the city? Or around the entire unfiltered layer? Are you using version 2.18.3 as well?
    – Spectre
    Feb 18, 2017 at 22:38
  • I experienced exactly the same issue with QGIS 2.18.14. However, the Grass 7 buffer tool works on this dataset.
    – ErikaP
    Dec 14, 2017 at 7:02

1 Answer 1

0

I can select Albuquerque using the expression builder ( "JURISDICTI" = 'ALBUQUERQUE' ).

enter image description here

I then select fixed distance buffer in the processing toolbox:

enter image description here

Enter 5280 in the Distance box:

enter image description here

Hit run, and this is the answer:

enter image description here

4
  • That's exactly how I'm doing it and getting an empty buffer layer. Well, you've confirmed it's not the file so I guess I'll try a reinstall.
    – Spectre
    Feb 19, 2017 at 15:29
  • FYI I'm using Win10. Uninstalled QGIS, restart, reinstall, restart, redownloaded files, still have the same problems. I'm trying to see where there are differences in the attribute table. If I forget about focusing on Albuquerque and open the attribute table for "jurisdiction" I get 116 features. If I try to buffer that entire layer I consistently only get 112 features in the new layer and the following are missing from the table (OBJECTID-JURISDICTI): 99-TIJERAS; 104-EDGEWOOD; 115-UNINCORPORATED AREAS; 116-ALBUQUERQUE. I don't see why these attributes would be treated differently.
    – Spectre
    Feb 19, 2017 at 22:33
  • are you setting the layer projection to EPSG:2903? one thing to try is selecting Albuquerque and then doing save as, with selected features only ticked and see what is in the new file.
    – Ian Turton
    Feb 20, 2017 at 8:51
  • Project and all layers are EPSG:2903. Also tried with EPSG 4326. I've tried doing a save-as for Albuquerque too and I still get the same blank layer with no attributes. I can perform this selection and buffer with any of the other 112 features that are "recognized" when I buffer the entire jurisdiction layer. The 4 features I listed above just vaporize. Other geoprocessing tools like Convex Hull on an ABQ filter works. I can also buffer the Convex Hull result with no issues. Is it possible the polygon complexity is an issue? It seems the simpler polygons work fine.
    – Spectre
    Feb 20, 2017 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.