0

I am new to GIS but slowly getting the learning curve. I am working with QGIS version 2.18.7. I have been editing several layers (both Raster and vector shape files) but suddenly the 'Toggle Editing' feature is greyed out and therefore I can no longer edit them. Although I have previously been able to do this. I have tried removing Filter but this still did not help. enter image description here

  • In order of understanding this problem can you make a print screen? Have you tried to re-save the layers and to work on with the new files? – Nitzan Matan May 31 '17 at 9:39
  • 2
    Do you have a layer/layer name selected in the layer panel? This is required to enable the edit pencil. – artwork21 May 31 '17 at 11:42
  • Yes , the layer is selected, I've googled the problem and tried almost all proposed solutions, to no effect... is there any chance that for some reason, the layers (not all of them) are corrupted in some way does this mean I will have to start from scratch... I suppose my question is realy... are there other users who have observed the same problem, or is there something specific to my own project... I have just downloaded the new version 2.18.9 maybe that will help – Simon Campbell Jun 1 '17 at 11:27
  • I have been using QGis2Web a lot in order to generate a web viewer of my data, is there any chance that for some reason this is effecting my ability to edit layers. – Simon Campbell Jun 1 '17 at 11:45
  • Is there any chance any other program is accessing the file? Does closing and reopening the project help? Sometimes I have come across this happen but not recently, and I haven't got a definitive reason why – she_weeds Sep 13 '18 at 2:10
1

I have just come across the same problem. Yesterday, I created a new shapefile in my QGIS project and edited it through "Toggle Editing" to add a few polygons. Today, when I reopened my project, the Toggle Editing button was greyed out when selecting this layer in the Layers Panel. The way I solved this problem was by removing the layer from the QGIS project and reloading it again. And voila, the Toggle Editing button became active again when selected the layer in the Layers Panel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.