3

I am attempting to take a Tif file that I received from a company and convert it to a geo-tif using QGIS. The original file(s) I received were the *.tif, *.tfw, and *.prj. I'm fairly new to working with geo-tifs, but have learned that the *.tfw is the world file that contains the points to line up the rasters and the *.prj holds the projection information. So I was able to import the Tif into QGIS, but it was not in the projection I wanted. After some research, I was able to convert the Tif to the right projection and I was ready to save it as a Geo-Tif.

However when I saved the Tif, the *.tif file I get was a solid black picture, not the colored map that I originally imported. I can load the original TIF in GIMP with no problems, but when I try to load the TIF exported from QGIS, I get error messages "Unknown field with tag 33550 (0x830e). I assume GIMP doesn't know what to do with the Geo-tag information and is erroring. However, when it does load the tif, it is a solid black map. It has lost all the colors from the original.

I've searched the site, but have not been able to find anything on this. Any ideas where I could be going wrong? The original files can be found at: Original TIF files zipped

migrated from gis.meta.stackexchange.com Sep 11 '17 at 6:46

This question came from our discussion, support, and feature requests site for cartographers, geographers and GIS professionals.

  • 1
    When you saved the layer as Tiff, did you change the output mode to Rendered image? It is on top of the Save As dialog window. – Kazuhito Sep 11 '17 at 9:53
  • 1
    THAT DID IT. Thanks. I was saving the raw data. – Jason Steffen Sep 11 '17 at 16:33
1

The following worked for me with QGIS 2.18.11:

  1. Make sure that the original .tif and .tfw files are located in the same folder.
  2. Add raster layer -> choose the original TIF file
  3. Set a CRS -> based on the .prj file which comes with the original TIF file choose EPSG:32613 (WGS 84 / UTM Zone 13 N). Depending on your settings you will be asked to choose a CRS when adding the TIF file as raster later or you will have to right click the layer in the layers panel and select "Set Layer CRS"
  4. Right click the layer in the layers panel and "Save As..." -> Format GTiff
  • That is what I ended up doing for getting the data in. Could have used these great instructions a few hours ago :-) It took me awhile to figure out how get it load the proper projection as I had it set to automatically load as WGS84. I had to figure out how to turn off the automatic assigning of the CRS. – Jason Steffen Sep 11 '17 at 16:36
0

Just assign the right projection via Raster -> Projections -> Assign Projections ...

Everything is fine. You GeoTIFF is in right place now. No need to Save as ...

enter image description here

  • Thanks, but I had no problem loading the data into QGIS. I was able to get it in and change the projection. The problem I was having was getting a Geo-Tiff exported back out so I could upload in another software package. The Tif was just a black map. As shown above, the other person found that I was not selecting the right output. Thanks for the comment though. – Jason Steffen Sep 11 '17 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.