I'm trying to get a public WFS into my QGIS Desktop (2.18.13) on Windows, so I tried adding an ArcGIS-FeatureServer-Layer and get the prompt:

Couldn't load service properties: :

I noticed, that QGIS is cutting off the URL I'm trying to use:


is cut off to:


If I paste the URL in my Browser, it seems okay, but:

  1. Is QGIS really cutting off URLs?
  2. Is there a way to shorten the URL? (I'm thinking of my Windows Host file or a similar solution)
  • 3
    I don't think this has anything to do with length, QGIS is just removing parameters that it intends to add it's self
    – Ian Turton
    Commented Oct 6, 2017 at 10:22

2 Answers 2


You can just add it as a standard WFS layer instead of as an ArcGIS MapServer Layer (I'm guessing &SERVICE=WFS is cut out as you're already selecting to load it as a WFS layer):

Layer > Add Layer > Add WFS Layer...

WFS layer




Another option would be to use a URL shortener such as google's. https://goo.gl/

  • This could cause problems with the service calls though, because QGIS will add the necessary request parameters for the operations it needs to do to get more information, or the data. You'll get conflicting request parameters, a request like ...request=GetCapabilities&request=GetFeature&...
    – nmtoken
    Commented Dec 4, 2020 at 9:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.