2

I was able to add a service connection to my GIS server over http, but not https in 4.8.2. I just installed AGS, Web Adapter, GE, and it's a brand new server that I just stood up.

https://gisserver.domain.local:6443/arcgis/tokens does not work, but http://gisserver.domain.local:6080/arcgis/tokens does.

When I put both URLs into a browser, they both work and my Username/password generates a token.

Obviously, I use my own GIS Server and Domain... What might be the problem?

enter image description here

  • 1
    When you navigate to just the rest end point of your server, do you get a security warning in your browser? If so, I suspect that its a trust issue. – KHibma Dec 11 '17 at 21:17
  • I do get a warning. Should I change my internet options or is it something to do with my SSL or IIS setings? @KHibma – Stella Dec 11 '17 at 21:20
  • PS. I have already added it to a list of trusted sites. – Stella Dec 11 '17 at 21:22
  • 2
    I'm weary of making this an answer as I could be wrong and sending you down an hours long process that doesn't solve the issue. But if it's the certificate being the problem, server comes with a pre installed self sign certificate. You need to get that imported into your machines trust store. Alternative you could go through the motions of installing your own self-signed, domain level or CA certificate (if you have that available to you). – KHibma Dec 11 '17 at 21:26
  • Quickest test that may solve this is these few steps of importing – KHibma Dec 11 '17 at 21:26
2

Geocortex Essentials will make a direct connection to the URL you specify in the map service connection. It's not going to use your browser here, so even if the connection works from the browser you may have to perform additional configuration to have the connection work with Essentials.

The first step will be to ensure that Essentials trusts the certificate used by ArcGIS Server. If you make a direct connection on port 6443, then the SSL certificate used may be the default self-signed certificate, which is not signed by a trusted authority and also may not be suitable for the domain name of the server.

You can either import the SSL Certificate into the Trusted Certificate Store for the server, or you can switch to using an SSL certificate that is issued by a known Certification Authority and that is valid for the URL. We recommend the latter, in combination with the web adaptor, as this allows you to use:

https://gisserver.domain.com/arcgis/rest/services/ServiceName/MapServer

as the URL for the service.

Note: In this case it is a good idea to explicitly specify the token URL. If it's not specified, Essentials will try to infer it from the map service URL. However, it will first attempt to use an SSL version of the URL to obtain the token (since we'll be sending a username and password over the network). If that fails for any reason then we'll blacklist the SSL address and switch to the non-SSL version. If regular HTTP is not allowed then we will not be able to obtain a token and the site will fail completely.

1

You are specifying a token url in the top section for the URL parameter, which should be a url to a valid ArcGIS REST Services directory (i.e. ends with /<your-instance>/rest/services) or folder (see their example pointing to an esri sample server).

Also, I don't think you have to enter the tokens url. Geocortex can find it automatically by calling info on the services directory. We have tons of connections and have never had to fill that in...

enter image description here

  • 1
    doh >.< I changed the URLS last minute for the screenshot. I ensure that they were valid service URLs. I just did a copy/paste and forgot to change it. Good catch though. – Stella Dec 12 '17 at 22:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.