2

I am trying to add a geodatabase (.gdb) vector layer into QGIS but I am running into an error. It says the .gdb file is not a valid or recognized data source.

enter image description here

I have spoken with the agency that maintains the file and they said it should work - it works fine on their end in ArcGIS Desktop. It's a version 9.3 .gdb file.

I have successfully opened and edited other .gdb files in QGIS. I use Directory --> OpenFileGDB. I am using QGIS version 2.18.15. What could be causing the problem now?

A link to download the GDB file is here: https://vgin.maps.arcgis.com/home/item.html?id=29627d7c051a47dc8ce71b4484531ab3

Here is a screenshot of the files within the .gdb file. Is something missing?

enter image description here

  • "it works fine on their end." In QGIS? Or ArcGIS? – Dan C Dec 14 '17 at 21:28
  • It works for them in ArcGIS – csft306 Dec 14 '17 at 21:32
  • @csft306 - Could you share your dataset or provide a link to it if it is available to the public? – Joseph Dec 15 '17 at 14:46
  • 1
    @joseph - Just edited the post to include the link. Thanks. – csft306 Dec 15 '17 at 14:51
  • Did you, @csft306, get to open the .gdb? I had the same problem with another dataset, tried yours and I am seeing the same problem. Running QGIS 2.18 64bit with GDAL/ORG 2.2.4 and QGIS 3.4.0 32bit with GDAL/ORG 2.3.2 on Win7. – R'n'E Feb 13 at 15:33
1

Not sure what version of QGIS you are using but try opening it using the "Directory", "OpenFileGDB" options:

enter image description here

  • This is the method I used and got the error. Directory --> OpenFileGDB... – csft306 Dec 14 '17 at 21:25
  • I'm using QGIS version 2.18.15 – csft306 Dec 14 '17 at 21:28
0

Try 'dragging & dropping' the files into QGIS. Not from the QGIS browser panel but directly from a file explorer window into the QGIS map canvas. I remember having a similar problem a while ago and the 'drag & drop' method worked for me.

  • Thanks for the comment but this didn't work either. – csft306 Dec 15 '17 at 14:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.