0

I reclassified a raster layer as a geotiffs using ArcGIS 10.5. The resulting reclassified raster had two values in the ArcGIS reclassify function, NoData and 1.

When I bring the geotiff into QGIS 2.18 the raster displays black with nan values. I have tried to reclassify the resulting geotiff using GRASS but that returned an error. Both QGIS and GRASS freak out over nan values!

How do I get this geotiff to display the nan values as transparent and the 1 values to display a color?

  • try to set zero values to null in with con tool or mask it out in ArcGIS in the first place. It might help – Amadeus Feb 3 '18 at 18:23
1

You probably need to set the nodata value for the raster. Using a tool such as gdal_translate with the option

-a_nodata -99999

or some other number that will never be used in your data, will likely help to get better results in bot ArcGIS and QGIS.

I hope this helps

  • This approach returned a new layer with the same problem. – GBG Feb 5 '18 at 6:40
0

Solved. In the Layer Properties-Styles set layer enhancement to No Enhancement.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.