2

I am setting up a new site in Geocortex Essentials manager. I'm adding ArcGIS server map services which are published on the same server. I can add the connection and the map services to the site but they do not display on the map screen. Both manager and map services are being accessed via HTTPS. I tried testing using https://sampleserver6.arcgisonline.com/arcgis/rest/services as suggested in another thread but again I can't see the map display. Any help would be great!

Blank Map Display

2

Geocortex Essentials Manager is a web application which uses the Esri Javascript API (and the Geocortex Viewer for HTML5) to show a preview of the map.

Some servers cannot run the viewer properly due to restrictions on what scripts may run or what protocol is used by the map services you're trying to see. The F12 developer tools should show you if any errors have been raised by the browser.

We often recommend using a workstation browser to access the Manager application rather than using it from the server - if you copy the URL to Essentials Manager and launch it from your local workstations' browser, do you see the map preview properly?

  • Thank you. Yes I can see it properly from my own machine. We'd like it on the server to have a central place for people to edit the application. Unfortunately we can only have IE on the server. The dev tools in IE don't show any errors. Will check with our network guys about restrictions for scripts. – AS.GIS Mar 28 '18 at 21:10
  • AS.GIS -- just access the RestManager from a workstation. Any user that could access the sever will have no problem getting permissions to view that server's sites, whether natively in their browsers over VPN or through an icon in their vpn portal. People will still be able to edit from their workstations. – Zack Apr 13 '18 at 21:23
1

Which version of Geocortex are you using? I know of an issue with the TIFF renderer, where they forgot to include it in the deployment package., The symptoms would be : adding ArcGIS map services works OK but you can't see them.

Try pressing F12 in Chrome browser and analyse the network throughput, see if any links fail to load.

1

A few things to check, on a general basis, not knowing anything about your setup:

  1. Are the folders in the layer list set to visible?

  2. If you use Layer Themes, are the map layers added to the correct layer theme?

  3. Are the permissions to view the site/map layer in question set?

GE Manager Permissions

  1. Also, are the AGS services secured or not?
  • Thanks for your help. I've doubled checked all those. The layers are set to visible. I've not set up any other layer themes. However after your comment I did try add the map services to a new layer theme but the issue still occurred. The AGS services are not secured. I can see the map services in the browser one the server (plus they are externally available) and appears in the the thumbnail for the site but just can't see them in Geocortex Essentials Manager. Any other ideas? Thank you again for your help. – AS.GIS Mar 20 '18 at 20:45
  • Did you check the permissions? Make sure your Guest access setting allow for accessing the site? (pic edited in above) – HavardMoe Mar 21 '18 at 9:12
  • Thanks again, I ticked all the permissions on (as per your screen grab) but the map services still will not display. Think it must be to do with the security set up on my server. – AS.GIS Mar 27 '18 at 0:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.