1

I am trying to import a shapefile into PgAdmin4. I do it with PostGis Shapefile Import/Export Manager. I have a « connection failed » message with no explanation so I do no know where to search … PostGis Shapefile Import/Export Manager message My datatable does not seem to have encoding problem anymore, my path neither .. And I can open the shapefile in arcgis/qgis. shapefile table

Does someone has a suggestion ?

UPDATE I set the correct SRID, still not working.PostGis Shapefile Import/Export Manager message with correct SRID

  • 2
    did you tried to define the SRID? – Moh Apr 25 '18 at 15:21
  • 1
    What happens when you open the connection detail and click ok? (it should attempt to connect to the DB) – JGH Apr 25 '18 at 15:41
  • @JGH I succeeded in connecting to the DB, which is empty. But then I can't import the shp – J.Delannoy Apr 26 '18 at 6:43
  • @User2009 Indeed srid=0, my SRID is defined for mon shapefile but not while importing. In the tutorials I red, thez said to define it after importing the shapefile – J.Delannoy Apr 26 '18 at 6:44
  • @User2009 my Postgis database is in UTF8 and my shapefile too, according to my cpg file – J.Delannoy Apr 26 '18 at 9:30
1

Finally, that was quite a simple stupid error : I forgot to enable postgis in this specific Database, as JGH mentionned !

If you have the same problem, run "CREATE EXTENTION postgis", and everything should work !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.