1

I created a plugin using the QGIS Plugin Builder with QGIS 3.2 and tried to compile it afterwards with the OSGeo4W Shell. In the Shell I navigated to the directory my plugin is installed (C:\Users\USER\AppData\Roaming\QGIS\QGIS3\profiles\default\python\plugins\MYPLUGIN) and typed in the following lines:

pyrcc5 -o resources.py resources.qrc

But I get an error, that pyrcc5 can not be found. But the batchfile is located in the Python 36->Scripts folder in the QGIS 3.2 folder.

I am using Windows 10.

How do I solve or workaround the error?

1

I managed to find a workarround for my problem, even though I did not solve the actual problem:

I installed the OSGeoW64 networkinstallation with qgis desktop and qgis full. Afterwards I installed pip and pb tool using the Windows console. With the pb tool deploy function compiling the plugin worked perfectly, no error messages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.