1

I want to see comma instead off points in my attribute table.

What happens is: When I import TXT or CSV there´s an option to use comma as decimal delimiter but after the importation I only see points as decimal delimiter.

What do I need to do?

Source CSV

enter image description here

Before

enter image description here

After

enter image description here

7

The settings you can control in the "Add delimited text layer" dialog is how the .csv file is being interpreted by QGIS when reading it. If your original file has a comma as decimal point (which it apparently has) this can be specified here.

After that however QGIS doesn't care about the file format any more and represents all decimal numbers in the same way (display format), wherever they may come from.

To control the display of decimal points, go to Settings -> Options -> General and check "Override System Locale" and switch the Locale to your preferred one. E.g. Italian or German (Germany) has comma as thousands separator.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.