1

This is what I'm working on:

enter image description here

How can I remove the parts of the land cover map that is outside the Baao map?

I can't use the filter function since the land cover map does not have location data:

enter image description here

3
  • For the Land cover layer, right-click and go to Properties > Symbology. In the Layer Rendering section at the bottom, set the blending mode for Layer to Overlay and the blending mode for Feature to Normal. Apply and make sure the Land cover layer is above the Baoo layer in the Table of Contents
    – Joseph
    Jul 30, 2019 at 10:44
  • It worked! Thank you!
    – BallpenMan
    Jul 30, 2019 at 10:52
  • Most welcome! Glad it helped :)
    – Joseph
    Jul 30, 2019 at 10:55

2 Answers 2

2

For the Land cover layer, right-click and go to Properties > Symbology. In the Layer Rendering section at the bottom, set the blending mode for Layer to Overlay and the blending mode for Feature to Normal. Apply and make sure the Land cover layer is above the Baoo layer in the Table of Contents.

This will only render the land cover which overlays the Baoo layer.

Note that this is only for display purposes. If you want to create a new layer which geometrically cuts the outer map, you can use the Clip tool.

4
  • Copy. Are you referring to the "Clip Raster by Extent" tool under the Raster tab? @Joseph
    – BallpenMan
    Jul 30, 2019 at 10:56
  • @BallpenMan - No since both your layers are polygon vector layers according to the image. There is a tool called "Clip" for vector layers only.
    – Joseph
    Jul 30, 2019 at 11:00
  • Thank you @Joseph. I'm running into some error but I got it from here.
    – BallpenMan
    Jul 30, 2019 at 11:11
  • @BallpenMan - No problem, The Land cover layer is huge so it may take time for the clipping process to complete. It would help if you selected the immediate polygons surrounding Baoo, save this as a new layer and then use this new layer (with less features) in the clipping process.
    – Joseph
    Jul 30, 2019 at 11:13
2

@Joseph is right. Here's how I did it (there's an error that others might encounter too).

  1. Use Vector > Geoprocessing Tools > Clip
  2. An error showed after running the tool. It said there is an invalid geometry and I should change the Processing setting to "Ignore invalid input features'option." See this Ignoring invalid input features with Intersection tool in QGIS?
  3. I did the suggested solution but error again. So, instead of "Ignore...", I picked "Do not filter." This is in Settings > Options > Processing > General > Invalid Features Filtering."
  4. I also used the "Check Validity" tool for both layers. You will get a Valid, Invalid, and an Error layer for both layer. Vector > Geometry Tools > Check Validity
  5. I now used the Clip tool using both of the Valid layers and done.
2
  • 1
    Also a good idea to fix broken geometries using tools such as Fix geometries or GRASS's v.clean to try and prevent issues like these :)
    – Joseph
    Jul 30, 2019 at 13:00
  • 1
    Copy. Thank you so much.
    – BallpenMan
    Jul 30, 2019 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.