0

i have extracted GPS data from photos using geosetter, so that I can then import them into ArcGIS Pro as a shapefile. This I can do but when I try to write the XYZ coordinates to the attribute table using either the 'Add XY Coordinates' or 'Add Geoemetry Attributes' tools i get a 0 or null respectively for the Z value. (the XY coordinates are written correctly). This is despite the fact that the features have Z values which are displayed in the pop up when querying a point. So how do I get this data into the attribute of my shapefile or feature class?

  • What’s this question have to do with KML (as indicated in the title) – KHibma Oct 14 at 12:23
  • this location data was extracted from image metadata as .kmz and then converted to shapefile in ArcGIS. – user116868 Oct 14 at 14:38
  • Using QGIS is a possibility? – Marcos Saito Oct 14 at 20:01
  • So you've used to KML to Layer tool to create the shapefile? Does the shapefile have an elevation field with the appropriate value? – KHibma Oct 15 at 13:34
  • perhaps re-reading the initial question may help but yes, i used the kml to layer tool. as you know this tool does not create a fully populated attribute table with an elevation field.this is why i have tried the tools to write the coordinates to the attribute file which just return a 0. all this despite the initial layer having full cordinates contained within the popup window when the feature is queried. – user116868 Oct 16 at 7:52
0

If you have basic license with 3D Analyst extension, standard or advanced licenses, you can use Add Z Information. The tool

Adds information about elevation properties of features in a Z-enabled feature class

I do not have any of the above requirements to test that, but you can give it a try if you have the proper license.

If you don't have the 3D Analyst extension, standard or advanced licenses and have access to QGIS which is an open source software, there is a tool named Extract Z values which:

Extracts z values from geometries into feature attributes

  • Thanks for the suggestion and as i do have 3D analyst, i tried the tool but it writes '0' to the Z field for all features. – user116868 Oct 14 at 12:08
  • You need to make sure that you dealing with Point Z geometry not just Point geometry. – ahmadhanb Oct 14 at 12:31
  • they are ZM shape file points. in the properties it states 'Z-enabled'. there are also Z values associated with the points that are stored in some part of the shape file as i have said if i query the point the pop-up shows the altutude. – user116868 Oct 14 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.