7

In QGIS 3.4 I'm trying to add a custom projection that was used for topographic maps of Suriname in the 1950s. I have the parameters from an article about historical CRS used in the country. Using the proj documentation I defined the custom CRS. I even tested it and the returned coordinates confirm that the projection does what I want. However, when I click OK to add the custom CRS, I get the popup: "The proj4 definition of 'Roussilhe Suriname' is not valid." error message

Here is the proj string:

 +proj=rouss +lat_0=4.11667 +lon_0=-55.68333 +k_0=0.9996 +x_0=300000 +y_0=775000 +ellps=bessel +units=km +no_defs

How can I test it, but then get the message that the definition is invalid? In any case, I now very little about proj4 and can't find the error. Below is a snip of the article containing the parameters. Source: PHOTOGRAMMETRIC ENGINEERING & REMOTE SENSING

13
  • 1
    Please copy your proj definition also as text for making it easy to copy and paste.
    – user30184
    Dec 13, 2019 at 13:15
  • The Roussilhe documentation doesn't list lat_0 has a supported parameter. You might try dropping the parameter as a check even though that will affect the Y/northing values. Also maybe try making the output values meters versus km. Both are guesses.
    – mkennedy
    Dec 13, 2019 at 22:02
  • @user30184 I've added the proj definition as text.
    – mkennedy
    Dec 13, 2019 at 22:05
  • In QGIS 3.11 the test does not run but it gives the same error immediately.
    – user30184
    Dec 14, 2019 at 15:44
  • 1
    @naught101 I had sent an email to the user list but it never got posted. I still don't have a solution to this
    – Gin
    Feb 24, 2020 at 2:42

4 Answers 4

4

I had the same error adding a new CRS. After a few try's I could finally add my CRS adding quotation marks to the name, in your case changing Roussilhe Suriname for "Roussilhe Suriname". After adding the CRS you can edit the name removing the quotation marks.

1
  • The quotation marks workaround did not work for me (Windows 10, QGIS 3.8) and where do you edit to remove the quotation marks?
    – Hans Erren
    Nov 19, 2020 at 9:11
4
+50

It might be a bug in that QGIS version. It works as expected in QGIS 3.10.14, 3.16.5, 3.18.1 (tested).

enter image description here

3

This is not directly an answer to the question asked, but someone may end up here with the same problem as I.

I had an 'empty' CRS line (blue line in the screenshot) and accidentally I tried to add another one and set the definition for that 'second' one. Even though all data for the second one was correct, when clicking ok, it failed with the error message "The definition of '' is not valid". After removing the first 'empty' CRS line with the minus, it worked.

enter image description here

1
  • That empty entry fooled me as well, well spotted !
    – Oyvind
    Jan 11, 2022 at 14:55
1

There is a problem with whitespaces. New versions of QGIS want spaces before every plus sign except the first one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.