0

The arrows point to the lines I want rid of, I drew them myself. This is a birds eye image of a portion of Scotland, and the 4 tiles contain geological information.

I have downloaded four geology tiles and merged them together. It works, and I can then go on to customise the tiles to colour code each geological unit no problem, but those four lines joining the tiles I merged look so messy and I want rid of them. I get these lines when I merge shapefiles to make the merged file, and when I merge layers to make the merged file. No solution as of yet.

I imagine it could be a stylistic thing, where I need to make the borders transparent or something. Thoughts?

1
  • 1
    Dissolve is one of the most common tasks, but you will lose all the other attributes, so selective merge operations in an edit session might be your best bet.
    – Vince
    Jun 7 '20 at 13:39
4

You can try dissolving features based on one common attribute. This should solve your problem. This may create multi-part polygons that you can break by Multipart To Singlepart algorithm.

1
  • 2
    Dissolve has an option 'no multiparts'.
    – FelixIP
    Jun 8 '20 at 2:50
0

So for geology maps specifically, I was able to rectify this by simply removing the outlines of the rock units after I filled them in. For the type of map I'm making, it is fine to just make your own boundaries with polylines, or just simply leave them empty because there is only one 'type' of geological boundary between rock units on this map and I think it actually looks better with no outline as this is more realistic given scales (too many geological maps have boundaries that are too thick).

However, fixing this issue for other purposes could be important to others so I will leave the question up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.