0

I am trying to index a Landsat8-Satellite-Dataset from Massachusetts in the USA. I downloaded the dataset from USGS. Below my question you can find the datacube-metadata.yaml-File. It is surface reflectance data and Analysis Ready Data (ARD). When I am now trying to index the data with: datacube -v dataset add PATH/datacube-metadata.yaml there occurs the error: ERROR No matching Product found for dataset

I think that the problem lies in the Product Definition File. I have used the Product Definition File from Swiss Data Cube: https://github.com/GRIDgva/SwissDataCube/blob/master/ingestors/Landsat/ls8_c1_ard_scene.yaml

I also tried to write one by myself but there is always the same error. Has someone an idea how to solve the error?

datacube-metadata.yaml-File:

acquisition:

aos:
'2018-10-30 15:32:36'

groundstation: {code:
_20}

los:
'2018-10-30 15:33:00'

creation_dt: 2018-10-30 00:00:00

extent:

center_dt:
'2018-10-30 15:32:48'

coord:

ll: {lat:
41.543343249666286,
lon: 
-74.26101678236896}

lr: {lat:
41.22740733220001,
lon: 
-72.50449089590899}

ul: {lat:
42.84901849362111,
lon: 
-73.84246819961363}

ur: {lat:
42.52663821973187,
lon: 
-72.05488589831796}

from_dt:
'2018-10-30 15:32:36'

to_dt:
'2018-10-30 15:33:00'

format: {name:
GeoTiff}

grid_spatial:

projection:

geo_ref_points:

ll: {x:
1784415.0, 
y: 2264805.0}

lr: {x:
1934415.0, 
y: 2264805.0}

ul: {x:
1784415.0, 
y: 2414805.0}

ur: {x:
1934415.0, 
y: 2414805.0}

spatial_reference:
PROJCS["Albers",GEOGCS["WGS 84",DATUM["WGS_1984",SPHEROID["WGS

84",6378140,298.2569999999957,AUTHORITY["EPSG","7030"]],AUTHORITY["EPSG","6326"]],PRIMEM["Greenwich",0],UNIT["degree",0.0174532925199433],AUTHORITY["EPSG","4326"]],PROJECTION["Albers_Conic_Equal_Area"],PARAMETER["standard_parallel_1",29.5],PARAMETER["standard_parallel_2",45.5],PARAMETER["latitude_of_center",23],PARAMETER["longitude_of_center",-96],PARAMETER["false_easting",0],PARAMETER["false_northing",0],UNIT["metre",1,AUTHORITY["EPSG","9001"]]]

id: 94675613-a468-45cd-850f-d6423beb4d61

image:

bands:

LINEAGEQA: {path:
LC08_CU_029006_20181030_20190613_C01_V01_LINEAGEQA.tif}

PIXELQA: {path:
LC08_CU_029006_20181030_20190613_C01_V01_PIXELQA.tif}

RADSATQA: {path:
LC08_CU_029006_20181030_20190613_C01_V01_RADSATQA.tif}

SRAEROSOLQA: {path:
LC08_CU_029006_20181030_20190613_C01_V01_SRAEROSOLQA.tif}

SRB1: {path:
LC08_CU_029006_20181030_20190613_C01_V01_SRB1.tif}

SRB2: {path:
LC08_CU_029006_20181030_20190613_C01_V01_SRB2.tif}

SRB3: {path:
LC08_CU_029006_20181030_20190613_C01_V01_SRB3.tif}

SRB4: {path:
LC08_CU_029006_20181030_20190613_C01_V01_SRB4.tif}

SRB5: {path:
LC08_CU_029006_20181030_20190613_C01_V01_SRB5.tif}

SRB6: {path:
LC08_CU_029006_20181030_20190613_C01_V01_SRB6.tif}

SRB7: {path:
LC08_CU_029006_20181030_20190613_C01_V01_SRB7.tif}

satellite_ref_point_end: {x:
29, 
y: 6}

satellite_ref_point_start: {x:
29, 
y: 6}

instrument: {name:
OLI/TIRS}

lineage:

source_datasets: {}

platform: {code:
LANDSAT_8}

processing_level:
T1

product_type:
LaSRC
0

I have found the solution: The instrumentname and the bandnames aren't exact the same in the datacube-metadata.yaml-File and in the product definition. If I change these names in the product definition the data is successfully indexed.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.