I am trying to run the "Near" tool in Arcmap. Both my layers involved are on a SDE database. When I run the tool I get the following error...

ERROR 000464: Cannot get exclusive schema lock.  Either being edited or in use by another application.

I do not:

  • Have an edit session open.
  • Have another application open.

I saw this Link but I do not have ArcSDE installed locally so cannot execute "sdemon -o kill" to locally kill all connections...

How can I get an exclusive schema lock and/or bypass this error?

Windows 7, ArcGIS 10, Versioned SDE GeoDatabase

After reading this:

"In the Windows File Explorer, I looked at the properties of the folder where my script was putting its data. I saw that the folder was set to READ ONLY." Source

I trying running the cmd command to set turn off read-only still no luck.

attrib -r pathTofolder

After further reading found that the read-only attribute in windows 7 is normal, and has more to do with windows system files then ability to write to the file folder.

Today after reconciling, thinking that all locks on the database world have been removed from the previous day. Tried running the "Near" tool again, but still no luck still gives the schema lock error...

  • Is your 'Near' operation the first geoprocessing call you're making on the layers? Is it possible that they have already been opened/loaded in Arc?
    – Radar
    Nov 14 '12 at 17:41
  • Yes I 'Near' is the first geoprocessing call on these layers. I have the layers 'Open' as in they show up in the table of contents of ArcMap. Nov 14 '12 at 17:46
  • What happens if you close ArcMap and run the tool from ArcCatalog?
    – L_Holcombe
    Nov 14 '12 at 18:44
  • From ArcCatalog Same Error.. Nov 14 '12 at 18:49
  • 1
    In ArcCatalog if you're running 10.1 you can right click on the SDE connection --> Administration --> Administer database and look at what or who is setting up the locks....maybe this will help narrow down the issue?
    – GISHuman
    Sep 20 '13 at 20:01

Try exporting the data to a local location (I personally use C:\Data), and attempt to run the tool on a local version of the data. If this works, you can load the data back into SDE. I've had too many problems with schema locks on SDE in both v9 and v10, and there are many ways to attempt to remove the locks. The problem would really come to a head if you can successfully run the tool on a local version and then NOT load the data back into SDE, which would indicate a deeper problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.