0

"Temporal/Spectral Profile Tool"-plugin runs into a Python error (below: reports import error in last two lines, entire error message is 14 lines):

QGIS 3.16.13 on mac 10.15.7, running Qt 5.14.2, QWT 6.1.4. In QGIS 3.10 the plugin runs properly.

I haven't found any earlier posts on this issue.

Error message:

_import
  mod = _builtin_import(name, globals, locals, fromlist, level)
  ImportError: dlopen(/Applications/QGIS-LTR.app/Contents/MacOS/lib/python3.8/site-packages/Pillow-7.2.0-py3.8-macosx-10.13.0-x86_64.egg/PIL/_imaging.cpython-38-darwin.so, 2): Library not loaded: /opt/X11/lib/libxcb.1.dylib
  Referenced from: /Applications/QGIS-LTR.app/Contents/MacOS/lib/python3.8/site-packages/Pillow-7.2.0-py3.8-macosx-10.13.0-x86_64.egg/PIL/_imaging.cpython-38-darwin.so
  Reason: image not found

1 Answer 1

0

CResolved: complete uninstall and reinstall to alternative build QGIS 3.16.8 while solving an issue with Semi-Automatic Classification plugin fixed also the issue with the Temporal/Spectral Profile Tool. Thanks to KyngChaos, Albert van Niekerk and Rachel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.