2

I'm not getting standard results from the volume tool.

Where am I going wrong?

I'm attempting to calculate the volume of a dam. I've used DEM data to create a contour level and I've selected the level that the dam will fill to in order to create the storage area. This gives me a polygon to feed into the area input in the tool along with the same DEM data that was used to create the contour level as the DEM Height Layer.

I then select the option to use a base level based on the average of polygon vertices.

This is where things get a bit odd. If I chose the option of 'Accurate Approximation' and run the tool using 1m increments (its a 10m high wall) I get 0m3 results, and the V_abnove and V_below columns are added to the polygon properties table with 0 values. If, however, I choose 'Simple Mean Value' instead, I get two additional columns added to the table, this time with data:

enter image description here

I'm assuming the _VHsum is the storage volume, but I don't know why I'm not getting V_above values. I'm using the same CRS for both layers.

4
  • 1
    Please provide details on your data and the settings you use for the calculations.
    – Erik
    Jan 17, 2023 at 10:17
  • 1
    Witch CRS are you using, is it a projected CRS, are the vertical unit the same as horizontal unit ?
    – J.R
    Jan 17, 2023 at 10:34
  • J.R - I checked all of my CRS and found that whilst the CRS was the same for both the input files, they differed from the project CRS. I've rectified that issue and it's fixed the problem - thanks very much for your help (and you too Erik).
    – PeterMac
    Jan 17, 2023 at 23:25
  • @PeterMac you should self answer your question so it appears as solved, this will help people having the same problem
    – J.R
    Jan 22, 2023 at 11:10

1 Answer 1

1

The problem was user error - i didn't have the DEM and the polygon in the same coordinate system. Once I changed them to the same CRS the issue was resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.