1

I have a grayscale DEM. From the screenshots it can be seen that the min max value of the pixels range from 267 to 270. However from the generation report (using Metashape) it is known that the actual heights range from 241m to 275m. How do I make the pixels in the raster correspond to these actual heights and not some seemingly random values it has picked?

enter image description here

enter image description here

2
  • 1
    I do not really believe that Agisoft is saving ramdom values into pixels. And QGIS shows the pixel values raw as they come from Agisoft. Could it be that the metashape report covers a larger area?
    – user30184
    Jun 4, 2023 at 14:41
  • @user30184 Ah that could perhaps be it. Might have to do some digging around in the source. Thanks for the hint
    – Aditya
    Jun 5, 2023 at 4:22

1 Answer 1

10

I had a similar SE-GIS question several years ago. The answer: by default, QGIS displays an estimate of the min/max values, which results in the unexpected values. To see this, open up the Min/Max Value Settings button, shown in your bottom screenshot.

To avoid the estimation, set the Min/Max Value Settings > Accuracy tab to Actual (slower).

For more detail and background, see the two (excellent) answers to my question at:

QGIS VRT values differ from the source rasters

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.