I am trying to find which areas a camera can view from a certain point inside a given circle (known radius).

I tried to use the Viewshed tool Arcmap provides in order to do that. I read here that I have to use additional options in order to define the radius and the offset.

So I created a point feature class as my camera's position. I chose the WGS_1984_Web_Mercator_Auxiliary_Sphere projection in order to have units in meters and I add one point as my observer point (camera). Then in the attribute table I added two extra fields OFFSETA and RADIUS2 and set the values to 1.5 and 1500. I suppose that the units is in meters because of my projection selection. Am I right?

The DEM file I use is in the WGS84 Geographic Coordinate System meaning that its units is in decimal degrees. Does this make any difference? I mean does the tool transform meters to decimal degrees or the opposite automatically?

Then I used Viewshed tool. The result had ignored the radius value and in the output raster there were areas away from 1500m. I tried using different values for RADIUS2 but nothing changed. I also tried it without the OFFSETA field supposing that there was something wrong with this value but again nothing changed my output.

Am I missing something?

I am using ArcGIS Desktop 10.

I think I dont insert the types of optional values correct. Should they be integers, doubles or something else? Maybe that is why the tool ingores my values and uses the default ones.

  • The vertical units will be determined by the DEM you choose and the horizontal units by the projection. Make sure the field type for your offset and radius match the tool inputs. I think they are double? – Rich Wawrzonek Jan 30 '13 at 23:02
  • I believe the units for both your datums are meters already – Rich Wawrzonek Jan 30 '13 at 23:09
  • The tool uses the extra options only if they are available so it doesnt define any input types for theses fields. – Mike Vasi Jan 30 '13 at 23:11
  • @RichWawrzonek I have seen that both DEM and the feature class share the same Datum (which is D_WGS_1984) despite the fact that i dont know what Datums are. – Mike Vasi Jan 30 '13 at 23:20
  • 1
    I don't think your problem is datum related. It is likely the tool inputs.The default RADIUS2 distance is infinity. It sounds like your input of 1500 isn't working so it goes to the default. The value for RADIUS2 should be greater than RADIUS1. – Rich Wawrzonek Jan 30 '13 at 23:44

Project your DEM and point file so that the map units are all in meters (to presumably match the z-values of the DEM). Alternatively, you can specify the Z_Factor to account for this, but for any surface analysis computation it is typically faster and more reliable if X, Y and Z units are all the same. The RADIUS2 is likely being read in as 1500 decimal degrees from the DEM.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.