No matter which feature to raster tool I use (feature to raster, point to raster, or polygon to raster), I am getting a raster output whose min and max values are 2147483647 and -2147483647, respectively.

Researching the issue came up with nothing much except a Wikipedia article mentioning that this is "the maximum value for a 32-bit signed integer in computing." I was relieved to discover that the number does, in fact, have some rational meaning, albeit one that doesn't make much sense to me...

I am attempting to convert evenly spaced (500 ft) points (and/or 500 ft vector grid) of elevation values to a raster. I'm not interested in interpolation. I simply want the raster grid to reflect the vector grid.

There are 6718 records, whose values, in increments of 100, range from 800 to 1600. The field type is a short integer with a precision of 4. I want to give an output cell size of 500 feet.

enter image description here

3 Answers 3


That's just the statistics. By default it is set to the minimum and maximum possible values. If you use the Calculate Statistics tool from the toolbox it should set those to more meaningful numbers.

If you don't want to calculate statistics in your layer properties you can change the minimum and maximum values of the display manually if you have a reasonable idea what they are. Set the layer symbology to minimum-maximum (possibly what it is now) and a check box appears 'edit minimum/maximum', check that and change the numbers. This will only affect the display and not modify the values of the raster itself.

  • No matter what I do (calculate statistics, change the minx/max, etc.) it always reverts back to the 2147483647/-2147483647 numbers... There must be something else going on.
    – Kristen G.
    Feb 13, 2013 at 14:56
  • I think you are correct in your answer, and now that I'm thinking about it, calculating statistics usually does the trick when you get seemingly strange output ranges. I just think in my case, something wacky is going on. See my answer below. Perhaps a projection issue?
    – Kristen G.
    Feb 13, 2013 at 15:20

So now it's working. I tried an IDW just for the hell of it, and I kept getting an error that there weren't enough points. I started thinking maybe there ARE no points... maybe it's a matter of projection. I exported both datasets (the points and the polygons) in the coordinate system of the data frame and voila, it worked!

Therefore, I'm thinking it MAY have been a projection issue.

I FEEL like there may have been more going on than that, but hey, changing the projection worked, and that works for me. Hopefully it will help someone else.

  • 1
    Projections are very important; if they're unknown or undefined that can cause real problems especially if the data is geographical (DD) and the cell size is in feet or metres. Another thing that can often cause nasty problems is the geoprocessing environment 'output extent'. By default the extent should be the extent of all the input objects but may be set to a manual extent to reduce results outside your AOI. If you have manually set your extent and forget to reset it to default then you can get empty results if you are working in a different area. Feb 14, 2013 at 23:37

Calculate the maximum, minimum, and range of the six input rasters. The outputs are rasters, not single values

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.