Skip to main content

Questions tagged [error-000816]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
0 answers
966 views

ArcGIS Editor for OSM, 10.8.x Desktop

Ran install successfully and created the OSM Toolbox but when download data give me error invalid. I am using ArcMap 10.8.2 with Background Processing
Hamed Algassi's user avatar
3 votes
1 answer
726 views

Publish geoprocessing service from Python Toolbox to ArcServer 10.7 from ArcMap

I have been trying to publish a python 'Hello, World!' sample geoprocessing service. I have ArcMap 10.7.1 and ArcGIS Enterprise Server 10.71. In Arc Map I started with a new Python Toolbox, and ...
freshop's user avatar
  • 131
1 vote
1 answer
2k views

esriJobMessageTypeError: ERROR 000816: The tool is not valid

I am trying to publish a model from ModelBuilder so that I can use it on my GIS-Web application, so to start with I have created a model with parameters for buffer, and tested it on ArcMap (Desktop) ...
Radouane Samaali's user avatar
0 votes
0 answers
1k views

Geprocessing Service: ERROR 000816: The tool is not valid. .Pyt file is fine but .tbx has red x's

I have a .pyt Python toolbox which runs fine in ArcMap and then gives the dreaded "ERROR 000816: The tool is not valid" when published as a GP Service. I've dealt with this issue many times before, ...
Josh Werts's user avatar
2 votes
1 answer
4k views

How to solve "error 000816: The tool is not valid" with ET Geowizards tools?

I have installed ET Geowizards 11.2 for ArcGIS 10.3 using setup.exe and followed the instructions. I am using ArcGIS 10.3. I can use ET Geowizards tools from the toolbar and I can run them in ...
user3811338's user avatar
2 votes
1 answer
182 views

Extract metadata with arcpy from orthoimagery

I'm very new to ArcGIS, and GIS is general. I am trying to build a script that will extract metadata from orthoimagery .tifs. Below is my test code to see if I can get the metadata from one file. It ...
JeremyGibson's user avatar
0 votes
0 answers
37 views

NVS Vector Stream Order Tool gives 000816 Tool is Not Valid in ArcGIS 10.2 for Desktop? [duplicate]

I am trying to use the NVS vector stream order tool (designed for ArcGIS 10.0) in ArcGIS 10.2. The tool is available for free. Whenever I attempt to operate the tool I am met with the error message: ...
jc22's user avatar
  • 425
2 votes
2 answers
1k views

.net Geoprocessing object: 000816: The tool is invalid [closed]

I am currently trying to build an ESRI Addin that supports multiple versions of ArcGIS (10.0 & 10.1). The project targets .net framework 3.5 and is built in the ArcGIS 10 environment. The ...
David Wilton's user avatar
  • 1,329
1 vote
4 answers
2k views

Do the Data Interoperability Tools need a Special Licence?

I am tring to add a function quick export from Data Interoperability Tools to a Model Builder in ArcGIS10.0 but I have an error called Error 000816: the tool is not valid. That is because I need a ...
mohamed nour eldien's user avatar
4 votes
2 answers
2k views

Is it possible to publish a geoprocessing services that uses a custom gptool on ArcGIS Server 10?

I have developed a custom GP tool in C# which does a bunch of processing on a given layer. It works great in ArcMap on all machines that I have deployed it to. I created a model which uses this tool ...
Devdatta Tengshe's user avatar
6 votes
3 answers
2k views

Using arcpy.ExportMetadata_conversion?

I don't know if it is a bug or my lack of python skills, but I keep getting 'ERROR 000816 The tool is not valid' in my python script when I call ExportMetadata_conversion Initially, I was attempting ...
Jay Cummins's user avatar
  • 14.6k