5

I have started having a problem with georeferencing.

When I try to add control points, the cursor just starts "thinking" forever, and it's nigh unusable. I've read forum posts that say this is an issue with GDI object leaks, and the advice is to reduce the number of rasters in the TOC. I only have one and it's a real small .jpg, so I just don't understand what's going wrong.

What could have changed on my system to cause such a drastic performance slump?

I am using 10.1 right now, though it was rather recently that I upgraded from 10.0. I'm fairly certain that I've georeferenced images since the upgrade, but maybe I haven't had to yet.

Is there a significant difference in how georeferencing works in 10.0 compared to 10.1?

The .jpg is stored natively (on the C drive), and actually, I think I did only try one raster. It was just such a normal little jpeg I didn't think anything of it. I should try another. I think Snapping may be the answer, actually. I was trying to snap to a huge point layer, and even though it didn't take long to draw (a misguided proxy for overall performance I realize), I think you're probably right about the issue.

I'll be able to fix this up tonight and give an update.


Yes, it was snapping, the point layer I was hoping to snap to was huge. Easy fix.

  • Does the issue persist if you try using a different image? – Kevin R Dyke Aug 8 '14 at 16:04
  • 2
    Where is your data being stored? Can you upgrade to 10.2 to test differences? Are you connected to network drives? – Baltok Aug 8 '14 at 16:05
  • I find raster performance to be significant better using tiffs than storing them in geodatabases – whatahitson Aug 8 '14 at 16:16
9

Turn off snapping (Snapping toolbar, uncheck "Use Snapping"). I've had this problem before when there are many vector layers in a project, the cursor is getting bogged down looking for a vertex (or edge, or whatever) to snap to. You could also try copying the image to be georeferenced to a new, empty ArcGIS project along with the bare minimum of vector layers you need to georeference it.

  • Yeah, I was already trying it in a new blank mxd with just the big point layer. but snapping does make sense as the likely culprit... – mr.adam Aug 8 '14 at 16:19
  • 4
    A fast way to check if snapping is killing performance (this applies to georeferencing, editing, and others tasks that utilize snapping) is to hold the spacebar down and see if performance improves. – DPierce Aug 8 '14 at 18:02
  • 3
    good idea. on a side-note, in terms of favorite keyboard shortcuts: in my mind spacebar-disable-snapping is only challenged by ctrl+shift+e to start an edit session. super great shortcuts. – mr.adam Aug 8 '14 at 18:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.