6

I am fairly new to actively work with databases. I wanted to try out some stuff on my home computer where I have installed pgAdmin and PostgreSQL previously. I can connect to my localhost in pgAdmin but I can't do the same in QGIS. I just get an error message saying:

"Connection failed -  Check settings and try again"

I am new in this game and don't really know where to look for solutions. My database connection info is standard settings:

Name: postgres
Host:Localhost
Port:5432
Database:test

Any ideas what could be wrong?

  • 2
    Chances are you are setting the service parameter, which has to be left empty. – Germán Carrillo Feb 6 '15 at 15:50
8

I'll add an answer with a screenshot, as it will be easier to look at for reference.

Here is an example with the absolute minimum you would have to enter. It would connect to a database called twitter, and I would name that connection twitterDB. Note that it does not matter how you name the connection; this is just a name you give to your connection so you can refer to it later on (see last screenshot).

enter image description here

And here a screenshot of the actual database I am connecting to:

enter image description here

In QGIS your connection would show up like this:

enter image description here

Hit the Connect button, and if it worked, the Schema area will be populated, where you can then navigate to your tables.

enter image description here

|improve this answer|||||
  • Thanks for you post and prtscreen! I think I had my settings in properly, but I will try again. Can reply with a printscreen of my settings. Wonder if it can have something to do with the installation of QGIS/postgres – geogrow Feb 7 '15 at 9:04
4

Name is the name of the database connection, you have to enter username and password below as well. Host should be localhost, not Localhost.

You might need Postgis as well, see

How to fix "Connection failed - Check settings and try again" when connecting to PostGIS?

How to connect to Postgres with QGIS?

qgis to local postgis connection - fails

for further advice.

|improve this answer|||||
  • Thank you for the advice and attached links, I realize that my questions is really generalized and not very specified, I will go through the links and try to sort it out" – geogrow Feb 7 '15 at 9:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.