0

I have a google Layer map on top of which I have added a raster layer of Image and then mapped image coordinates from Google layer.

I made transparent (75%) image map layer and now mapping and creating polygons on top of image layer (Added new shapefile layer) I drew few polygons and then saved it.

When I reopened the file, clicked on toggle editing, I could see my polygons, but I am not able to add/edit/delete existing/new polygons in that shapefile layer. (All icons are disabled)

Is this expected behavior?

My old question on what exactly am I doing. How to create/obtain district data for Singapore?

  • Have you tried saving and restarting QGIS? When I've had similar errors this can resolve the issue. – Phil May 20 '15 at 9:28
  • Yes, I did try that. Did not work – Neil May 20 '15 at 9:36
  • Have you checked file permissions for the newly created shapefile? Is it writeable? – Phil May 20 '15 at 9:53
  • have you ensured that your shapefile layer is highlighted in the layer list(left side)? I think it might be needed for the editing tools to be active. – vinayan May 20 '15 at 9:56
  • I created it. So I should have the write permission. I also updated it to give all permissions to all users. Didnt help – Neil May 20 '15 at 9:59
1

I've tested this on both my laptop (OS X) and my desktop (Ubuntu) but not a Windows box. As @til_b says, the problem seems to be that the .dbf has a different name to the .shp and .shx files.

After renaming the file behaved much better.

I also suggest you dissolve the layer using Vector > Geoprocessing Tools > Dissolve toolset.

After dissolving I was able to add, delete and edit features.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.