1

Is there some way to "repair" rendering in ArcScene?

As you can see on the picture some of the polygons are not rendered correctly it's probably because polygons are overlapping each other. In arcmap i was able to set up "symbol levels" so there wasn't problem but i'm not able to set up "symbol levels" in arcscene. Polygons are at the same shapefile.

enter image description here

  • This appears to be an issue with surface clipping. In 3D, the z value controls draw order. If your polygons are at the same elevation, it's hit or miss which will draw on top. If layers are conflicting with each other or with a DEM surface beneath, you'll want to set them up with small vertical offsets so they appear above the surface and other layers. For example your grass might be .01 above surface, play area .02, and walks .03. If everything is in the same feature class, then you'd have to have a z or offset value attribute to use to specify base heights. – Chris W May 30 '15 at 7:16
  • @ChrisW For this case i solved it manually (simply by cutting polygons). Anyway thank you for your advice. I was think about idea to add Z value as you wrote and probably it's the best solution for future. Since heights like .01 or .02 are probably negligible. – L.s. May 30 '15 at 13:54
1

You need to set Drawing Priority for EACH layer in the scene. This is in the rendering tab of the layer properties. In some cases even this will not help, especially if you have any transparencies set. ArcScene simply cannot resolve some complex scenes. The work around is to modify your features in such a way that there is no possibility of overlap and avoid transparencies. You may also want to consider a 3D party option such as Sketchup.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.