1

I am using Ubuntu 14.04 and I would like to know the easiest way to install the latest (stable) version of Osmosis, which is 0.44.

I ran

sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
sudo apt-get update
sudo apt-get install osmosis
osmosis -v

That last command returns many lines, but the second is

INFO: Osmosis Version 0.40.1

0.40 seems to have too many problems with 64-bit integers. So I want to download the latest stable, but I don't know where Osmosis is currently installed to and thus where I should copy the downloaded files to.

http://wiki.openstreetmap.org/wiki/Osmosis#Downloading

5

Finding the location of your current executable can be done with which and ls -l can show you where the symlink points:

which osmosis | xargs ls -l

If you know the location just follow the Install instructions for pre-built binaries:

wget http://bretth.dev.openstreetmap.org/osmosis-build/osmosis-latest.tgz
mkdir osmosis-new
mv osmosis-latest.tgz osmosis-new
cd osmosis-new
tar xvfz osmosis-latest.tgz
rm osmosis-latest.tgz
chmod a+x bin/osmosis
cd .. 
mv osmosis-new/* /your/osmosis/install/location/
  • Ahh, the which command, I need to remember that more. It returned /usr/bin/osmosis which was a file rather than a directory. I tried several things before deciding I was best to delete my attempts and start the installation from scratch (into any folder in my home directory that I won't delete). The readme.txt contains instructions to make a symbolic link in your user bin (probably what that file was!) and now I've done that I can return to using the osmosis command without caring where it is. – Gregory Jan 4 '16 at 12:54
  • Somewhere on my computer I guess I have an old copy of osmosis, I should do a file search for that if I want to clean it up. If you update your answer to mention which may return a symbolic link, then I will happily mark it as the correct answer. Thank you. – Gregory Jan 4 '16 at 12:54
  • @Gregory valid remark. I included the listing of symlinks and where they point to – Kersten Jan 4 '16 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.