I'm having some problems adapting a few models inherited by me from a colleague.

Inside this model, we attempt to calculate Summary Statistics, but the model can't find the field that it needs to use. ModelBuilder refuses to show it to me, despite the fact that the Feature Class in this calculation possesses the field in question.

Has anyone seen weird problems like this one?

The original model was for 9.3 and I'm rebuilding it in 9.3.1. Any pitfalls I'm not aware?

  • Upload the model somewhere and either myself or someone else should be able to spot the issue pretty quick.
    – jakc
    Sep 9, 2010 at 13:17
  • Hello Simon, unfortunately I cannot do that :/. It's not a model error, it's something more like a bug. The model works fine on the machine where it was first built, but not on subsequent machines. Sep 9, 2010 at 13:40

3 Answers 3


Try running the model from 'Edit' mode only up to the output just prior to the 'Summary Stats' tool. Then open the Summary Stats tool and see if the correct variables, etc have populated. Sometimes models need to be run once successfully before populating the 'next tool' correctly. It's wierd, but on the rare occassion that has happened to me, that usually works for me. Validate the model as well, then save.

  • This does not work for me. Even validating, saving it does not work. It initially worked fine and I did not have this problem. Then I changed my license to Advanced, the only thing I can think of that has changed, and I get this problem.
    – ndthl
    Sep 11, 2013 at 7:46

Summary Statistic "Case field parameter data type has been changed."


Hopefully the 'workaround' works for your complex model

Hope there are no spatial joins in the model.... (issues there too)

affects 9.3, 9.3.1 in Windows Environments

  • I'll take a look into it. Thank you very much mapperz. Unfortunately, there are also spatial joins :P Sep 9, 2010 at 16:36

I have shared models before, and they have done some similar things. Have the 'new user' try what I have suggested above.

Please share the resolution, if one is reached. Thnaks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.