I am trying to connect to Harvard's darmc/roman map. I was able to get it to work in ArcGIS. However, I need everything in QGIS because all my data is in there.

The error I'm getting is:

the server you are trying to connect to does not seem to be a WMSserver please check the url?

I got the link from:


WMS server link


The error message is correct, the service URL that you list is not an OGC WMS.

Don't panic though you should still be able to access the data using QGIS. The way you may do this is different according to version of QGIS you are using. If you are on the QGIS Long Term Release version (2.14.8 LTR) you should be able to use the QGIS plugin ArcGIS REST API Connector to access the data.

More details on the plugin can be found here:


The plugin is experimental at the moment but you can access individual layers, for example the springs layer is shown below:

Springs feature layer from darmc in QGIS

If you are on QGIS 2.16 or higher, support for ArcGIS services is native, and accessible through the Layer Menu; however like @bugmenot123 I find that whilst I can connect to this service and get the list of layers, as below:

ArcGISMapServer connection to roman stuff

I get an error when trying to add any data:

Invalid Layer: AMSProvider Could not parse spatial reference Raster layer Provider is not valid (provider: arcgismapserver, URI: crs='EPSG:3857' format='PNG32' layer='51' url='http://cga-app01.cadm.harvard.edu/arcgis/rest/services/darmc/roman/MapServer/WMSServer'

I'm not sure if this is buggy behaviour from QGIS, or some error with the service iteslf, or user error...

  • Nice, should it also work with the built-in ArcGis MapServer support? Nov 23 '16 at 21:01

What you are trying to access is not a WMS but a service using ESRI's proprietary REST protocol. You should be able to load it via Layer -> Add ArcGis MapServer Layer. For me it breaks the dialog but that might just be a bug at my end.

  • For me, that Layer -> Add ArcGIS mapserver layer option is not there. I have needed to add the plugin and then I can find the option under the Vector menu. I'm using QGIS 2.14.4
    – Johanna
    Nov 23 '16 at 21:16
  • 1
    You people and your old versions... It's a new feature since 2.16 :) qgis.org/de/site/forusers/visualchangelog216/… Nov 24 '16 at 8:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.