1

I am trying to load WMS layer from geoserver in QGIS. The Error in QGIS is : Failed to Download Capabilities Download of Capabilities failed: Connection Refused

So I went and found this question: Failure to connect QGIS with GeoServer WMS?

but the solution in the first answer when I go to the following link:

http://localhost:8080/geoserver/wms?SERVICE=WMS&REQUEST=GetCapabilities

I get an XML Parsing Error, how can I fix this error?

XML Parsing Error: not well-formed Location: http://localhost:8080/geoserver/wms?SERVICE=WMS&REQUEST=GetCapabilities Line Number 6244, Column 50:
-34.8977165222168http://localhost:8080/geoserver/schemas/wms/1.3.0/exceptions_1_3_0.xsd">

Ok Update: Some of the sld styles did not have workspaces assigned to them, once they were sorted I still cannot load th WMS in QGIS.

When I load the localhost get capabilities link same as above ^^^

I no longer get the same error message(progress?)

But now the error states: This XML file does not appear to have any style information associated with it. The document tree is shown below.

  • Download the GetCapabilities into disk with the GetCapabilities URL, open the file with text editor and tell what do you see on line 6244. – user30184 Oct 13 '17 at 10:31
  • line 6244: <southBoundLatitude>-34.8977165222168</<?xml version="1.0" encoding="UTF-8"?><ServiceExceptionReport version="1.3.0" xmlns="opengis.net/ogc" xmlns:xsi="w3.org/2001/XMLSchema-instance" xsi:schemaLocation="opengis.net/ogc localhost:8080/geoserver/schemas/wms/1.3.0/exceptions_1_3_0.xsd"> <ServiceException> – Dave303 Oct 13 '17 at 10:39
  • In sublime text the first '<' after the Latitude value is highlighted. – Dave303 Oct 13 '17 at 10:40
  • There seems to be something wrong with your server. Can you see your layers with the Layer preview demo of your Geoserver? – user30184 Oct 13 '17 at 10:50
  • I can preview layers in Geoserver. The instance of geoserver is running in docker if that changes things slightly? – Dave303 Oct 13 '17 at 10:53
2

One (or more) of your layers is broken. Goto the global settings menu and change the Service Error Settings from return service exception to skipping misconfigured layers.

enter image description here

This will now work in QGis but one (or more) layers will be missing. You need to look at why those layers are not working.

  • So it looks like somehow some of my styles 'lost' their workspaces and these were the error layers, am hoping this may fix it. thanks – Dave303 Oct 13 '17 at 11:09
-1

I faced the same error too so I change my Z value and M value layers from enabled to disabled, and it works!

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.