2

a few days ago I decided to update my QGIS 2.14 into a QGIS 2.18.

I uninstalled the old version and installed the new one, normally. Then nothing at all happened when I pressed the icon.

I uninstalled, deleted all registry mentioning old installations of QGIS, reinstalled 2.18, and still nothing.

I tried installing QGIS OSGEO4w, but again, nothing.

I changed the Qgis.bat to add the system folder

PATH %systemroot%\system32; %systemroot%; %systemroot%\system32\wbem

, and nothing..

I really don't know!

Clearly I also tried to install back the 2.14, but it does not launch either.

Any suggestion?

  • Have you tried running the qgis.bat file or loading the OSGeo4W Shell and typing in qgis? – Joseph Jan 16 '18 at 11:21
  • yes.. not even the OSgeo shell is launching, actually.. – user34423 Jan 16 '18 at 11:28
  • Might I suggest starting again: uninstall QGIS, delete the .qgis2 folder (located in /Users/You/.qgis2, back up any scripts or models if you made any), if using Windows run the regedit program and delete everything related to QGIS. Restart your computer then do a clean install using the correct QGIS setup (32-bit or 64-bit). See if this helps. You shouldn't need to modify any paths, it's weird nothing seems to load. – Joseph Jan 16 '18 at 11:37
  • I tried this several times, actually, and it didn't work at all. I don't know why. Furthermore, now that I have installed everything through OSGeo4W I don't even have the uninstal option! – user34423 Jan 16 '18 at 11:56
  • Please make sure you uninstall your osgeo4W install via the osgeo Setup : gis.stackexchange.com/a/256500/25139 – gisnside Jan 16 '18 at 20:41
1

You can delete the OSGEO folder, including all the installed applications. (This is usually installed at C:/).

If you do this, and then run the most recent OsGeo4W installer and install again, that should sort it.

  • Thanks. I installed already everything using the latest OsGeo4W installer, and yet nothing was starting.. – user34423 Jan 17 '18 at 13:10
  • Is your OS 32 or 64 bit? What version of the installer did you use? – Alex Leith Jan 17 '18 at 21:11
  • It's a 64bits. The installation through OsGeo gave some error at the end, but I don't know what exactly. I'm going to try again now. I downloaded the latest version a couple of days ago but I cannot read the version. – user34423 Jan 18 '18 at 8:38
  • You'd better take note of the error, hey! – Alex Leith Jan 18 '18 at 11:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.