0

I am exporting map to pdf using ArcGIS Pro at 600 dpi resolution. The exported map is coming with some thin colored lines. I tried to export same map to png it appeared fine.

Am i missing something here regarding export settings for pdf ?

I have an interpolated raster these lines are reflecting the colors of that raster.

When i un-check that raster then it prints pdf fine.

I cannot include complete map screen shot but i am including the area where i dont have data. See the green lines in image.

enter image description here

When i select these blocks and right click i get the option to copy image. Seems like different small images have been stitched to generate this pdf.

enter image description here

  • 1
    Have you checked this question although it is quite different (thick lines appear not thin lines)? gis.stackexchange.com/questions/240124/… – ahmadhanb Nov 13 '18 at 8:02
  • 1
    @ahmadhanb That was my first thought too. – PolyGeo Nov 13 '18 at 8:17
  • No no, its not like this. I am editing the question to include image – user4906240 Nov 13 '18 at 8:46
  • Have you tried removing the raster from the mxd and then uploading it again? It seems like there is a corruption occurring then translating to pdf and starting with a newly added layer has worked in the past. – MapinTX Nov 13 '18 at 21:12
  • Yes done that and even changed the symbology but still same issue – user4906240 Nov 14 '18 at 4:49
1

One of the issue is with the transparency of raster

https://support.esri.com/en/bugs/nimbus/QlVHLTAwMDA5NTc2NQ==

Other issue is that ArcGIS Pro while exporting map to pdf do not have option to rasterize(ArcGIS Pro will get this in 2.3 version)

https://community.esri.com/ideas/14201-generalize-vector-data-on-export-settings

The solution of this problem is instead of sharing it as a pdf, Use the Print option print to file and while printing, Select Microsoft print to pdf. This results in rasterized map in pdf and it appears fine.

enter image description here

Update Now you have the option in version 2.3

enter image description here

This resolves the issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.