2

At 10.7.1, here's the first part of a model I am creating. Please note that I have parameterized the input and output:

enter image description here

My problem is within the Project tool: I want it to always use the same datum transformation, but I am unable to get that transformation to appear. When editing the model, I can drop-down the tool's transformation list, but I cannot make the selected transformation "stick" in the transformation box; the box remains blank. Weird, because I can select the desired Output Coordinate System just above.

I think that the problem has to do with the parameterized input, because if I hard-code an input shapefile, the transformation sticks.

enter image description here

How do I "force" the desired transformation to appear in the model while still allowing parameterized input?

EDIT:

For this tool, the input data will always be NAD83 (specifically: NAD_1983_StatePlane_Washington_North_FIPS_4601_Feet

and the output data will always be NAD83 HARN (specifically: NAD_1983_HARN_StatePlane_Washington_South_FIPS_4602_Feet / VCS:NAVD_1988)

When I Project these two manually, Arc offers a variety of transformations. I always select:

NAD_1983_To_HARN_WA_OR.

This is the transformation that I want to force my tool to use.

4
  • 1
    A GeogTran is only necessary if the source GCS is not based on NAD83, at which point, the UI will offer all the potential transformations.
    – Vince
    Mar 5, 2020 at 17:58
  • @Vince good point! That's probably the issue.
    – Hornbydd
    Mar 5, 2020 at 18:33
  • Both good comments, thanks. But in my case I need a transformation. Please see my edited post.
    – Stu Smith
    Mar 5, 2020 at 22:42
  • Stu you could try creating a model variable and set it to the required transformation and link it to the tool parameter, pretty much as I show in my answer?
    – Hornbydd
    Mar 6, 2020 at 9:22

1 Answer 1

2

I'm using ArcMap 10.6. My test scenario is projecting from BNG to WGS84.

I set up the following model and when I set the output coordinate system in the Project tool it auto-selected the transformation for me. I then exposed it as a parameter

Model

So everything worked for me. The only thing I can think of is does your input dataset have a coordinate system? It would need one for project to even work.

2
  • Your kind efforts really helped. Although parameterizing the GT works, it unfortunately forces the user to drop-down and select the desired transformation every time the model run - and that transformation value will be the same every time. That's why I'm searching for a way to hard-code that transformation into the model.
    – Stu Smith
    Mar 6, 2020 at 15:17
  • @StuSmith I suspect the Projection tool is doing some sort of internal validation which is causing the drop down to reset and not stay as transformation you have set.
    – Hornbydd
    Mar 6, 2020 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.