I have been georeferencing Vector files (gpkg and shp) in the new Georeferencer in QGIS 3.30.1. The files are pretty large, have multiple million features and a size of roughly 2-3gb.

I have successfully georeferenced 2 of those files with no issues in the georeferencer, but when attempting to georef 2 additional files (which have been created through the exact same process and model) I got this error:

OGR Driver error: not found (OGR:

I have tried a lot of things, including:

Trying different georef algorithms, repairing the geometries, trying to georef them as shapefiles, running QGIS on a different machine, completely reinstalling and installing the newest version of QGIS

but to no avail.

I still cannot georeference them. This is especially puzzling since with the other two files (created equally and of actually bigger size) i had 0 problems.

Do you have any insight on where this error comes from, if it is related to the files themselves or rather the nature of QGIS and OGR?

  • 1
    Shapefiles won't work if they are bigger than 2Gb and are pretty unreliable at 1Gb even.
    – Ian Turton
    Commented Jun 6, 2023 at 10:53
  • A vector geopackage i georeferenced earlier was 3.3gb of size and it worked well. With around 50 GCP and on Polynominal 3 i got accuracy up to 2-5m which is enough for my usecase. So i suspect it cannot be the size that is causing the error as the files that fail have a size of only about 1.5gb
    – David SSS
    Commented Jun 6, 2023 at 11:11

1 Answer 1


I found the solution! It is a weird one but hear me out.

This issue is related to the FILENAME you give your georeferenced image.

The files i wanted to georeferenced were named: final_geopackage_9_12_13.gpkg

When georeferencing QGIS automatically changes this into final_geopackage_9_12_13_modified.gpkg

When i tried to save a the file under this name i got the OGR Driver error. However under a different name it worked.

But it gets weirder. Simply changing parts of the filename dont work either. For example when changing the name from final_geopackage_9_12_13_modified.gpkg to final_geopackage_9_12_13_georeferenced.gpkg or maybe final_geopackage_9_12_13_Lets_hope_it_works_this_time.gpkg WILL NOT WORK.

Dont ask me how or why but OGR seems to get tripped up over any resembelance to the original filename.

Renaming the file to e.g Peter.gpkg or ABCD.gpkg made the error disappear and the georeferencing work flawlessly.

  • 1
    Fantastic, I came across the same issue as well and this fixed it, thank you! In my case it was because there was a full stop (.) in the filename before the actual extension - removed just that and the rest of it worked. Maybe it depends on what OS you are using too in terms of filename compliance.
    – she_weeds
    Commented Dec 21, 2023 at 5:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.