0

I have a shapefile containing cadastral data. I would like to dissolve the polygons using my field "OwnerName". My goal is to get one polygon per landlord's name.

When I use the "Dissolve" tool, QGIS creates an empty output layer (but with the right column titles, see the screenshot attached).

First I thought that maybe I could not dissolve some polygons using a field containing some text (my "OwnerName" field), so I created a field containing a decimal number ID for each owner name. I tried to dissolve the polygons again. Same result : an empty layer. The reason may be the size of the attribute table. I have 65,500 polygons.

Any idea?

Thanks enter image description here (QGIS 1.8.0 Lisboa - Windows 7)

  • can you display the results i.e screenshoot of the dissolved output? – Arun Sep 13 '13 at 3:52
  • I have attached a screenshot of the empty attribute table of the dissolved output. Thanks – Bap Sep 13 '13 at 18:42
  • What happens if you try "dissolve all" options, regardless of the attribute value? – Michal Zimmermann Sep 14 '13 at 6:28
  • When I "dissolve all" the tool stops around 60% of completion. I tried a few times with the same result. – Bap Sep 25 '13 at 17:31
1

The problem was the size of the shapefile. I ran the Dissolve tool over the week-end and it worked. It took 40 hours to complete the process. The first 1% shows up after 45 mins. I was not patient enough and though it was not working while actually I should have waited longer. Thanks

  • 1
    Consider using postgis or sqlite for speeding up things. Look for instance for st_unaryunion – Curlew Oct 2 '13 at 16:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.