After running the r.los algorithm through QGIS 2.0, I'm getting a 'Problem loading output layers' box which gives the following message:

Oooops! The following output layers could not be open Output raster layer: C:/Users/ffinnm/Documents/CGE/LVIA/Southdown/gis files/viewsheds/hhh.grd The above files could not be opened, which probably indicates that they were not correctly produced by the executed algorithm Checking the log information might help you see why those layers were not created as expected This algorithm requires GRASS to be run. A test to check if GRASS is correctly installed and configured in your system has been performed, with the following result: GRASS seems to be correctly installed and configured

I have checked the log information and there is no error logged here. Interestingly, in the log information, the algorithms section states that the 'r.voronoi' algorithm ran 2 seconds after the 'r.los' algorithm. I didn't instruct the r.voronoi algorithm to run (or know what it is!).

I have also tried changing both input and output raster formats.

  • I had error in r.los used in Processing when not setting the bound of data. Are you sure there are no errors at all in the log. Can you post the log just for the r.los function call. !enter image description here
    – Jakob
    Feb 25, 2014 at 10:04

1 Answer 1


If anyone has the same problem in the future, I've figured out how to solve the problem (but not why it happened!):

In the R.los window, when inputting 'Coordinates identifying the viewing position', do not copy and paste them from a spreadsheet. Either type the coordinate in, copy and paste them from a text file, or use the 'Coordinate capture' tool within QGIS and copy and paste them from there. R.los will then produce the raster.

  • Not for me! I did exactly as you suggested above, typing in the coordinates. I tried saving results to a temporary file (that is default), and I also tried saving results to a specified, especially-created file. Each time, I got that exact same error message you posted in your initial question.
    – Catlike
    Feb 10, 2014 at 22:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.