0

I have a parent model with several nested models. I'm having trouble getting the parent model to validate. The issue is with sub model 4. The two screenshots are of the parent model and sub model 4. The output from sub model 3 feeds into parameter “Merged_BBK_Assets” in sub model 4. There are no other input model parameters in sub model 4. If I run the first three sub models then open, validate and run sub model 4 from within its model window, it runs fine. The Merged_BBK_Assets is created in sub model 3 and does not exist till then.
Sub Model 4

Parent

2

According to the help the Make Query Table tool takes a Table View as input. In your parent model, right click on the output of submodel 3 and select the properties and make sure data type is of type Table View.

  • Hornbydd, thank you for the response. The output type is "Feature Class or Table". I've tried converting the output of submodel 3 to a table and that didn't resolve the issue. Furthermore, I have another set of models performing a similar task and the "Feature Class or Table" view output is accepted as the input to the Make Query Table. – Steve Mar 25 '14 at 13:04
0

Perhaps the validation issue is where you are editing the models from? ArcGIS gave me trouble if I edited sub-models from the Catalog, but no trouble if I edited them from inside the main model.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.