4

I have a problem with in which order my vector and raster layers appear in QGIS. I have raster that I want to be the background of my other layers (vector). I place the vector layers on top in the TOC, but some of them still end up under the raster layer in the display? I have check there projection and that's the same for all layers. I have also tried putting the raster layer on top in the TOC, but the resault is still the same.

I just want to show a few vector layers on top of a raster, but in this version something goes wrong. I have never had any trouble with this in earlier version of QGIS.

Any ideas on how to solve this?

6

Rightclick on a layer, and check Update Drawing Order. Prior to QGIS 2.0, this was part of the Table of Content.

Sometimes it helps to save and open the project again.

  • There is a also a panel for setting the layer order. View panels. Then there is a toggle to have layer order managed separately to tree order. – Willy Apr 7 '14 at 10:31
  • A question on this, in order to have the layer order on display to be the same as tree order, which panels should be activated? At the moment the only one I have active is 'layer'. – SoS Apr 7 '14 at 11:33
  • If the checkbox is set according to my answer, the layer order is identical to tree order. If you uncheck Drawing order, you can use the layer order panel. Or check Control rendering orderon that panel. It unchecks the Drawing order automatically. – AndreJ Apr 7 '14 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.