3

Trying to use raster extraction clipper to prepare a selected area of the map for generating contours - keep getting the error message:

ERROR 1: TIFFOpen:everest_gmted30.tif: Permission denied

Any clues on what to do about this?

  • 1
    Is your file called everest_gmted30.tif? I'd say it's a file permission problem.. are you trying to overwrite the original with the output (never a good idea)? – Michael Stimson Nov 13 '14 at 1:23
  • I am new to QGIS-previously used ArcGis- and am working through a tutorial to work with terrain data.So far it has instructed me to download a GMTED2010 dataset from USGS. This has been done and I have added it as a raster layer and changed the co-ordinates to zoom in to the area to be worked on. This is just as outlined in the instructions and conforms with what is pictured in the tutorial. I am then instructed to 'In the Clipper window, name your output file as everest_gmted30.tif.' Having done that I then follow the instructions to clip the file - each time I do so I get the message. – JayC Nov 13 '14 at 8:27
  • 1
    To avoid any permission-related issues, I always save my shapefiles on the desktop (in folders ofcourse) as I found that saving it to various directories within my C: drive would show up with error messages. – Joseph Nov 13 '14 at 13:12
  • Thanks, I will try that - I saved it in the same file as the downloaded dataset – JayC Nov 13 '14 at 13:24
  • 3
    By default, the files are saved by QGIS to somewhere inside the installation folder. Windows does not give you write access there by default. – AndreJ Nov 13 '14 at 13:38
3

I had this problem as well, considering I am working through the same tutorial as you, and it worked for me only when I named the file through Windows. In other words, I clicked choose file and my location then named it just like the person who wrote the tutorial, and it went through.

1

I encountered this problem as well and it took me a lot of time to figure it out. Turned out the solution was simple (but not obvious). Instead of writing just the filename in the space for "Output file", you should write the full filepath.

Do this by 1) clicking on "Select..." 2) type the filename in the "File name: " slot 3) click "Save"

After you're brought back to the "Merge" window, click "OK".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.